Remote Tilt Setup Guide

Super easy install using the BKB voyager! Thanks so much for your help Nico!

2 Likes

Got mine setup as well. Thanks for the clear documentation! I can’t wait to get this out on a pump track to play around with it.

1 Like

I could use some help. I’m not exactly sure what going on but it seems like a firmware issue. I’m using the Hoyt puck so it is PPM. I changing the connector to correctly match up to the 3pin servo port. I set the app config to uart and PPM. PPM mapping worked fine but it did take a couple tries to get it right.

However after the set up, once I power cycled the board, the motor becomes very crunchy. I can spin it by hand and feel it crunch around. The PPM remote is also not being detected in PPM mapping. The remote is indicating that it is paired or else it would be blinking. I can switch the app config to PPM and the problem is the same. Only when I switch to “uart only” and back to “uart and PPM”, does the remote start to read and the motor crunch goes away. Writing the change both times. This is repeatable.

Once I do that everything works as expected. It feels soooo good. I really hope this is a simple fix because I love it. I can also report that having input tilt disabled in float config does not effect this issue.

Im confused, what’s the issue? The App to Use should be left as UART, what you’re describing is normal. It sounds like it’s working perfectly fine when App to Use is UART, which it should be, so what’s the issue?

Do you need App to Use to be set to UART and PPM for some reason? If so, i believe you might need a custom firmware change, as if i remember correctly, PPM automatically does some weird braking behavior when a remote is connected, which causes what you’re describing, with no great way of disabling it.

1 Like

OK. All is well. I’m just a little slow. I was confused because ppm mapping only works if you select ppm or ppm and uart in app config. I remembered uart should be active so I chose ppm and uart, PPM mapping is how I was determining if the remote was working. All I had to do was switch it back to uart and hop on to test it instead. Thanks for your response!

1 Like

Ahhh I gotcha now, desktop VESC Tool. Yeah for that you gotta switch to PPM to get access to PPM Mapping and that throttle gauge. On mobile VESC Tool, you can do PPM Mapping without changing App to Use by going to App CFG, tapping the “…” in the bottom right, and selecting PPM Mapping. This screen can also be used to make sure the throttle is working in the first place, though you can also check by looking at the Remote Input value in the Debug section of the AppUI tab’s RT Data, if you’re on the latest Float Package and the Remote Type (Float CFG → Remote) is set to PPM

2 Likes

I just got one of these and I’m going to be using with a Ubox75. I had the Spintend UART Bluetooth module, and now I’ve got the BKB receiver too. I would like to be able to use Bluetooth and the remote. Can I either connect the BKB via bluetooth, or does the BKB receiver actually serve Bluetooth function too? I was looking at using PPM as well. I don’t want to spend more, but maybe this receiver would be a solution if none of the ports on the BKB receiver work?

edit:
Actually, this text

From here
leads me to believe maybe it will work via bluetooth module?
I’ve made some attempts but have yet to get it to pair.

I tried getting this to work, but I couldn’t get the PPM to show up with the Little FOCer 3.1. I keep hoping it is a firmware issue that gets resolved at some point, because my Bluetooth is definitely not as robust using the internal module. The controller support with UART is pretty awesome though. It’s nice to have another speed and battery readout available.

More context / details are needed to help here, what do you mean you can’t get PPM to “show up”? What remote are you using? How did you wire the reciever? Did you do PPM mapping like explained in the guide? PPM works completely fine when set up properly, I use it every day with a Hoyt St. Puck remote on my street board

1 Like

I’m having an issue with my BKB Voyager remote setup that I’m having trouble tracking down. I have the board tuned so that without the remote connected everything works perfectly. No noise, very smooth running and strong. When I connect the remote I start getting motor noise. The noise is present when the board activates and is there regardless of the remote throttle position. It is loudest at 0 to low speeds and then seems to quiet down and almost go away completely above about 5mph. The remote does work. The board tilts up and down like it should, but the motor noise is significant. If I then disconnect the remote, the noise is still present until I turn the board off and back on again without the remote connected and the noise then disappears.

I followed the instructions on the BKB site and I did the gear calibration. I tried resetting the remote to defaults and doing the setup again.

Not sure what else would cause this or what to check. Any ideas?

My setup:
FOCer 3.1 - FW 6.02
Float Package v9
Superflux
BKB Voyager

Took me all winter, but I’m almost done…

As stated in the guide, no App CFG changes should be made, that section of the BKB guide should be skipped. Under App CFG → VESC Remote, set Control Type to None and Write. Restart your board to be sure the change goes through. If this doesnt work, make sure everything else in that VESC Remote tab is set to defaults as well.

2 Likes

Ah! Can’t believe I missed that. That was it. Just switched the control type in the VESC remote tab to Off. Nothing else was needed. No noise now. Thanks Nico!

3 Likes