OWIE Wiring & FW (Use FM BMS for 15s VEXR)

Hey maybe a second question about the purple cable : isn’t the 63v running through this tiny cable ?

Yes, but it is more of a signal wire. So low amps as it’s not doing more than just telling the BMS that the charger has been plugged in. The majority of the current/amps are sent down the other path.

At least that’s how I understand it. I have been running 3 boards this way for a couple of months now without issues.

1 Like

all rights, thanks !

Damn it, just finish all the wiring, and it seems I’ve got a issue with the official charger.
When I plug it in, its led turns red and blinks making a “tick” noise at every blink.
The VESC is powering on, I can connect to it with bluetooth, and when I plug in the charger I can connect to OWIE…
Did you have this issue already ?

oh sh*t I’ve inverted the + and the - on the left handside female xt60… I’m so lucky nothing went wrong, even for the BMS.
It’s seems to be charging well, We’ll see later about the balancing.
Thanks a million for this guide !

1 Like

This is all very useful, although I used a different method to flash the ESP8266. There’s a web app that the OWIE repo links to; you just connect the chip to your Windows machine via USB, open the web app, and follow the directions. GitHub - lolwheel/Owie

1 Like

I tried that, but I didn’t have very good luck. It wouldn’t let me load the latest firmware.

Glad it worked for you

That’s scary… polarity mix ups… Glad you got it sorted.

1 Like

The web app currently has an older version but you can flash that first, then do an OTA update to the latest version. I talked to one of the developers and they’re working on updating the web app to the latest too.

Yeah. Maybe it has been fixed. Last time I tried it wouldn’t work for me so I had to go the route I shared here. But I’m glad that option appears to be working again now.

A note in case anyone has trouble with OWIE not reading data correctly - I had this problem and it turns out the white wire on my FM BMS was different from older(?) BMS’s. The OWIE RX should be wired to pin 5 on the 6 pin BMS connector (the purple wire is pin 1). On mine, a late 2021 OW, there was no wire at pin 5 and the white wire was at pin 2. Removing it from the connector and moving it to the pin 5 slot fixed the issue.

Compare this screen grab from a JWFFM video:

With my connector:
image

2 Likes

Hey Ya! Any news about that purple wire going directly to charge positive on the bms? I was planning to do this to simplify a custom harness, cant figure out why not?!

I think I tried what you are suggesting and I do not recommend it. This is a picture before I added the data wire, with hot directly to the purple pin from the charge wire…

The result of this configuration us a latching effect and the BMS remains on after the charger is removed. It’s because when the purple wire turns on the BMS the two XT-60 connectors on the BMS are connected. Now the purple wire can receive voltage from the battery. No way to turn the BMS off without disconnecting the purple wire (red in my example) or the battery itself.

Hey buddy! (Izzymonster i assume? Me=Vommbat;)
Thanks for taking the time to reply. Yes, i was planning to do this but what you say makes sense!! So i will hook purple up to the 3rd pin . Is it ok if i post your reply on the discord. I was literally advised it was fine like i planned it;)

Heya. Yep izzymonster. Sorry I don’t use discord. Since you are just getting to it, you should know there is a small mistake in the first installation diagram above. You’ll see the purple wire is going to the pin closest to the balance connector, which is incorrect. It is correct in the next diagram, below, where the purple wire goes to the pin closest to the xt connectors. That threw me off but I just looked at the stock harness.

Wait…what? Which diagram? I installed it exactly like the diagram by Haverr(?). Purple from pin closest to charge XT60 to port3. No luck. Charger blinks red/green couple times then goes steady green but pack is not charged.

I’m also having trouble. The Haverr diagram should be right as far as I understand it, pin closest to XT connector. Here is my implementation with a +XR 4206 BMS.

OWIE is working and reporting correctly. What does not seem to be working correctly is the charger. My understanding of Li ion chargers is that as the the battery approaches the charge voltage, the output current is reduced. This allows the battery to get closer and closer to the charge voltage without going over 4.2V per cell. In my case the charger is not reducing output so it cannot get to max charge voltage without the BMS shutting off due to a cell reaching 4.2.

Here’s how it goes. Charging normally

Almost at max charge voltage but not reducing current:

Max charge voltage. No reduction in current. BMS is about to cut out at 4.2V

BMS cuts off. No charge current.

After this the battery voltage will settle for a bit and then BMS will reengage. It will charge for a short time before the BMS disengages again for the same reason. It will repeat this cycle a certain number of times before the BMS faults and needs to be power cycled.

I feel like there is something I am not understanding about how the charge interacts with the BMS. I will try a DC-DC charger I have that I know profiles the current correctly. It also allows me to adjust the output current and voltage. I will let ya’ll know what I find. I appreciate any other insights.

1 Like

Disclaimer: I am not an expert. Consider that what I say might be wrong. Make your own educated decisions. Be safe.

After some head scratching I figured this out. The short of it is that there is another electrical element in the +XR controller that is in series with the BMS. This element causes a small voltage drop before the BMS so that the BMS receives a voltage slightly less than the charger is outputting. If you remove this element, the voltage delivered by the charger is now higher than the BMS expects. The BMS will cut out before the charger has a chance to reach maximum charge voltage where it begins to reduce output current and enter the balancing phase.

Now the long version. You’ll see from my previous post that the BMS cut out just above 62.7V. This is what the BMS wants to charge to. The +XR charger on the other hand puts out about 63.3V. So where does the 0.6V go? To figure that out we can look at this trace diagram of the +XR controller. We are particularly interested in this section:


Here we can see from batt+ we head up into a black rectangular element then to a solder joint which is the + charger connector on the other side. Looking up the text on the element, 10H10, we find this. It is a vishay 100V rectifier/diode. This diode is rated for 100V and 10A with a forward voltage (or expected voltage drop across the element) of .88V. Taking a closer look at the documentation we can see in Figure 2 a forward current of 3A (our charge current) will result is a power loss of about 2W. 2W divided by 3A is 0.67V which is just about the difference between what our BMS wants and what our charger puts out.
222

To solve this I am going to add a diode to my charge adapter. I am trying to match the rating of the 10H10 and the forward voltage so that I have a similar drop. I have found this and this. Although the forward voltage is slightly less than what I want. If it is giving me trouble because the voltage is too high I plan to trim with ~30mOhm resistor to reduce .1V at 3A.

I feel like this may have been discovered before. I could have sworn I’ve seen a video of surfdado installing a diode but the reason didn’t click with me at the time. Also you should know that this could be different with different models of the BMS. From pictures I can see on the pint BMS there is most likely a diode on that instead of the controller. The model of board I pulled from is 4206 +XR.

1 Like

I’ve looked over the wiring and did the flash for the esp. Got the esp to establish a wifi and show the balance firmware but not getting any data from the BMS. I’ve tried a few things but with no luck.

Screen shows a connection time. with no amps no cell data.

I have a FM 4209 BMS and following this guide.

You can double check your work with the github if you haven’t already. I’ve seen some wiring mistakes in different guides but the git and jwffm chip stuff is all correct. You might also check conductivity on your purple wire and white wire from the esp to the BMS board to see that your connectors are making good contact.

1 Like