Motor turns in reverse, imu shows upside down

Inverse motor from motor config (add screenshot)

Change pitch in the vesc app from 0 to 180 (screenshot)

Just to clarify I just encountered this, but I wasn’t sure if the original post was a question or an answer. I now see it was an answer. I did both setting the motor to inverse and and set the pitch to 180 and it fixed it.

But on another note, when I try IMU calibration on this lil focer 3.0 it puts crazy values into roll/pitch. It seems the only way I can get it to work is to put 0 in roll/yaw and 180 in pitch manually.

I calibrated a lil focer 3.1 with no issues other than setting the 90 yaw.

@pevdevadmin - does it matter if I set pitch to 180 or roll to 180? If I set roll to 180 in some configs I don’t have to invert the motor. So far I haven’t seen any adverse effects of doing this, but just figured I would ask in case I may have missed something.

@makerspev your thoughts?

i usually 180 degree the z axis but i have never seen an issue with doing it on a different axis, 180 degrees is 180 degrees