Refloat - A new VESC Package

The repo (somewhat confusingly) contains all packages, here’s the Readme for Refloat:

That’s also the Readme you see when you open the package in VESC Tool for installing.

Can you try and embed it here in the first post as well? Or at least add an FAQ for users?

give me 2min, I will preformat it for you in first post

I’m reluctant to copy-paste the Readme. I think I’ll probably link it instead and try to maybe improve the post structure a bit…

Thanks for the help!

1 Like

Riding this package has been great but I noticed that all beeping from my board has stopped, my board no longer beeps on boot or to indicate duty cycle. Also do you intend to implement haptic feedback?

1 Like

I don’t have a beeper myself, it’s possible something broke about it at some point. I guess I’ll go order one.

Haptic feedback is planned in a future version. Not sure how soon it’ll be, as I’ve got a huge backlog of things to add and improve…

It also seems like I can’t uninstall the package from my board now. No matter what I try to do to get the original Float package back it just says refloat on the config and I don’t have access to haptics.

Disconnect and reconnect to the board.

Have done that multiple times. Also the board shuts off after the uninstalls. Is that normal?

Is there a terminal command I could run to remove the packages?

What do you mean by shutting off? Unless you have a momentary switch, it’s not possible for the board to shut off by itself.

What’s your controller?

Are you using mobile or desktop VESC Tool?

When you install the package, it all goes through without an error?

There’s no command to remove packages, there’s an uninstall button on the packages page. You can try to do that, then completely reboot, then install Float. First time I’m seeing these issues though…

If you know how to use the terminal you can type “threads” to see if Float or Refloat threads are running. You can also type “faults” after the installation, to see if there was a fault.

I have a momentary button on a ubox 100. When running the uninstall package from the packages tab the light goes off after a second or 2 and the board seems to shut down. It gets disconnected from vesc tool. Although it says complete before it disconnects. When I reboot and just leave it for a bit Refloat cfg page returns. I can’t seem to go back to float package. Running vesc tool on my iPad and iPhone. Have tried multiple times on both.

Ok, that looks like a serious VESC bug… let’s take it to DM so that we don’t spam here.

Hey! Are there any pans to migrate this to float 2.0? Either way, I’m going to gibe the split Kps a go this weekend. Thanks for the innovation. I also found the roll to be too damped on my growler.

Something’s gonna be worked out, @surfdado has made it apparent he wants to transition to Refloat codebase. It’s just a question of what name it’s going to bear, and that has little practical impact for the users.

1 Like

I wanna give an update on @ednom3try’s controller.

We tried to debug it for a while, the controller was acting weird. At the beginning I assumed Refloat is messing with the package installation process, so we tried to make it not run Refloat after startup. This is normally possible, but the controller was not displaying running threads properly, would reboot on its own at certain points and the momentary button functionality seemed to bug out and play a role in this too. Ultimately, Refloat running or not didn’t seem to play a role in this, but it’s not conclusive due to the observed inconsistencies.

After some trial and error we found out the controller failed to erase (or, subsequently, write) the Lisp / main package code flash sector, and, when we resorted to attempting to flash the FW, the controller failed to erase the main FW flash sectors too. Strangely, it was willing to flash QML / App UI, and, it was working in the sense that it’d operate, Refloat was running and balancing.

Conclusion is the controller is semi-bricked and it looks to be a hardware failure. There’s nothing in the package that could really cause this. The controller was sent for RMA, I don’t expect to find out much more about the failure… :slightly_frowning_face:

This look promising !

I’ll give it a try next week on my Floatwheel. Anything particular to be carefull about ?

There are no known serious problems right now. If you have a flashed LCM that works with Float, it’s broken on Refloat right now, but @surfdado has already found the issue and the fix will be in the next beta release (ETA a few days).


Some feedback based on a few days of riding ~100km / 62mi.

The transition was completely seamless; it took me 4 minutes and kept all my Float package settings intact. I haven’t delved into the separate Mahony KPs yet, nor have I checked what the configuration is, so this could be a placebo effect, but I’ve noticed slightly better turnability and an overall smoothness in some contexts.

Waiting on beta 4 to have light control for floatwheel :slight_smile:

1 Like