Custom Firmware not installing properly (Not Bootloader Issue)

I’ve been attempting to load @surfdado 's latest V3 Firmware but seem unsuccessful. I’ve tried the previous V2 IMU Bump Comp firmware as well, along with uploading the generic bootloader from the VESC Tool, and doing all the same on both PC and the Android VESC Tool app. There’s no indication of any kind of error, but upon reconnecting, it appears to just load up the old default Stable 5.3 FW, and modified app settings that should appear in the newer FW are not present. Any ideas?

Which VESC is it? LFOCv3? I just learned that the UBOX firmware didn’t get built for V3 so it includes the 5.3 stable instead

Oh wait - are you expecting to see new labels in the VESC Tool? No, those won’t appear. To the VESC tool all config parameters still look the same. The config parameter labels are hard coded in the VESC tool. So you probably have successfully loaded my fixed 5.3 versions you just can’t tell.

The quickest test is to set deadzone to 1 and see if the board rides just like before or whether it acts all weird.

Ahh gotcha, I could’ve sworn I read somewhere that it should show in the “VESC Firmware, Hardware and UUID” window, but I could’ve just been mistaken.

I was also confused by the settings seen in your newest config video (different labels and units compared to mine) and was expecting to see the same on my end post-update, but went back to the video and totally missed that you mentioned it’s part of the upcoming ATR firmware, my bad! I am also still missing Deadzone being Integral Limiting though, did you just modify your VESC Tool to list the intended units? And if I’m on the proper firmware, “2.8 degrees Deadzone” would really be “2.8 x 10A Integral Limiting”?

At least from workbench testing it does seem solid still with deadzone increased and D set to 0, I’ll have to take it on a ride once rain clears up. Thanks!

1 Like

the fact that your board doesn’t ride like crap with deadzone > 0 means that it worked :slight_smile: