ATR Firmware / Configuration

Configuring ATR

1) What is it

ATR stands for adaptive torque response, it replaces torque tiltback. The basic idea is that instead of just looking at amps to determine whether the setpoint needs to be adjusted, ATR compares expected acceleration to actual acceleration.

2)Requirements

#1 Requirement is a working board with stable 5.3 v3+ firmware!!!
#2 Is your board having some isses and you’re hoping ATR will fix them??? You will be disappointed!

This only works with custom firmware, it’s not part of 5.3 stable. Here’s the firmware files for all 5.3 hardware (sorry, no Ubox 100V yet)

ATR v18 ZIP File - Only use on working boards

Note: “CAN bus” does work since v18

IMPORTANT: ATR sucks balls if you try it with V4 app configs, so read on...

3) How to load

*The usual firmware loading procedure: Backup your config before loading firmware, select custom file, and DO NOT load the wrong firmware, LFOC v3.1 isn't the same as LFOC v3.0!!!*

PLEASE LOAD FROM PC ONLY!

Note: Windows Bluetooth will not work with VESCs, so you connect via your phone and create a TCP Bridge (checkbox on bottom of first page in app) - note the IP address of the phone (must be on same wifi as PC!!) - then in the PC choose TCP connection

4) How to configure

After loading the firmware, make sure you load my XML file after restoring your own settings:

VEXR_ATR.xml (2.8 KB)

This file is hand-edited and safe to load, it won’t overwrite any of your personal settings like IMU calibration or fault/tiltback settings.

Configuration is done using the existing torque tiltback settings plus yaw_ki in the Multi ESC section. And it also uses the biquad filter values on the Tune page.

For all details see the table in this google sheet:

Would love to have this table right here, but how do I create a table without going full HTML?

How to test whether the firmware download was successful? The revision number (12, now it’ll be 18) is being reported in the RT data screen (the last one) instead of “Loop Time” when first starting up (it switches to actual loop time after you first engage the board)

I recommend to stop right here, try my ATR xml file first. Once it's all working smoothly you can consider moving to Max's settings

5) Release Notes

v18 - 20-Sep-2022:
  • CAN BMS current limiting permanently disabled

v17 - 6-Sep-2022:

  • More stable battery percentage
  • SimpleStart feature (think Badgersense SureStart), permanently enabled atm

v16 - 26-Aug-2022:

  • Disable ATR (revert to plain torque tilt) by setting TT-Filer to 0Hz
  • Improved hardware filtering for LFOCv3.1 (LSM6DS3 TR-C IMU)

~ Hey there this is Max. I’ve attached my most current trail settings (motor & app) using the CBCSO 84V battery. Make sure you 1) download Dado’s ATR firmware for Little FOCer v3, 2) upload my settings, 3) reconfigure the current, voltage, faults etc for your battery appropriately if you’re not using the 84V CBCSO!! 4) Press ‘WRITE’ for both Motor AND App settings. These settings feel pretty damn good. Can hit 27-31 mph without tiltback. Rips on trails without nose hunting. A quirk to be smoothed out is the motor will crunch when you are braking fast and hard, and when landing a bonk/drop leaning backwards slightly. No biggie tho. Give it a try and let me know! Shoutout Dado, Uy and Hannes for helping me tweak these settings ~

(MK2 means my 2nd MakersPev focer board, NW means Northwest Electric Fest where the board hit those speeds)
MK2 Motor Settings 84V (Trails) Post NW fest.xml (9.7 KB)
MK2 App Settings 84V (Trails) Post NW fest.xml (11.1 KB)

BTW (this is Dado now) - Careful when loading Max’s XML files - they wipe out all your existing settings! If you do want to load them, you will have to redo all your motor configuration, IMU calibration, battery voltage setup, ADC/fault/startup tuning the way you like it…

2 Likes

I was originally on firmware 5.3.002 but I wanted to check these settings out. I loaded the ATR firmware and notice a couple of improvements I really liked straight away:

  • your torque tilt settings
  • going downhill feels soooo much better being able to angle the nose closer to the ground

The only issue i noticed it was dipping a fair bit in acceleration. Tried playing with a ton of settings but could not get it to stop. Probably missed adjusting the settings that would help.

Uploaded the 5.3.004 firmware to my board and the dipping did not exist anymore.

You are right Tiz, due to the absence of torquetilt during flat acceleration the board remains a lot softer. Hannes is complaining about this too…

2 Likes

What can I do to tighten up the feel of my board running ATR? I’ve tried tightening things up as one would with V4, adjusting Mahoney KP and P/I values but it still continues to feel extremely loose. It’s a good feeling. I just tend to like my board a bit stiffer.

See row 80/81 in the spreadsheet: in the NRF section you can enable torquetilt (for acceleration only). Give 20 a try.

1 Like

Woah! Thanks! Will have to give it a try in the morning! :call_me_hand:

@surfdado I just updated to version 16 ATR to test it out and still have crazy dip through acceleration. Tried row 80/81 but it made no difference.

1 Like

Same here, I tried the nrf torque tilt option and it doesn’t feel like it’s working. At least not how it works when you disable atr by putting filter to 0